Using normal nagios plugins with nagwin - Possible?

3 posts / 0 new
Last post
FoxtrotOff
Offline
Last seen: 6 years 3 months ago
Joined: 08.10.2013 - 13:45
Using normal nagios plugins with nagwin - Possible?

Hey everyone

I have a quick query. I am looking at implementing NAGWIN as our Monitoring software for the network i look after, i have tested nagwin by using it just to ping the hosts i am looking after but i want to go more in depth with the monitoring of our SAN's and NAS's

Anyway, i have found some plugins that normal nagios works with to monitor our SANs and NASs however i have been struggling for the past week trying to get normal nagios and linux to work and i can no longer be bothered with it.

Basically the question i have is as follows: Will the plugins i have found work with nagwin? its basically going to decide weather or not we invest into nagwin or go for something else windows based

Thanks everyone.

P.s. i am using fujitsu's own plugins for their dx60 and 80 SAN's and the check_thecus.pl file for an N8800

itefix
Offline
Last seen: 8 hours 30 sec ago
Joined: 01.05.2008 - 21:33
The plugin you mention uses

The plugin you mention uses screen scraping and comes with the following warning:

HINT: This application does screen scraping of the web interface. This might cause errors, e.g. other firmware version is used or other language etc.

Relying on plugins with screen scraping is not a good practice as there are serious issues with data reliability and quality.

That said, assuming that Perl JSON module is installed via cpan, that module would work at a Nagwin installation.

FoxtrotOff
Offline
Last seen: 6 years 3 months ago
Joined: 08.10.2013 - 13:45
HI tk, Thanks for your reply,

HI tk,

Thanks for your reply, i noticed you edited the post but caught the jist of it in my email

The SAN plugin id be looking to use is the following:

http://www.fujitsu.com/global/support/products/computing/storage/disk/download/nagios-plugin.html

And the ones for our nas's are as follows, i was going to try both and see which worked as there isnt one for our specific NAS

First one,

https://exchange.nagios.org/directory/Plugins/Hardware/Storage-Systems/SAN-and-NAS/Thecus-NAS-Health/details

The second one you have already found as linked in your previous reply.

Ill have to double check the install i performed on the server tbh as when i did i wasnt going to go so deep into monitoring our SAN's but we lost a disk last week and the hot spare didnt pick up, so it would have been bad had we not manually checked =-)

Thanks again mate