Nagwin/Winpre Different Services to Define

13 posts / 0 new
Last post
mig1980
Offline
Last seen: 8 years 9 months ago
Joined: 13.10.2012 - 01:17
Nagwin/Winpre Different Services to Define

Good day. Where can I find a list of all services available to monitor within Nagwin? I setup the default which appears with 12 services being monitored for each host but I don't know what some of them mean or how to resolve the Critical ones.

 

Thank you in advance.

itefix
Offline
Last seen: 2 days 38 min ago
Joined: 01.05.2008 - 21:33
Nagios uses plugins for its

Nagios uses plugins for its service and host checks. A common set of plugins like cpu, memory, disk, services and event logs are provided in plugins directory. You can check commands behind those 12 service checks to get an idea of what they do. We think that they give a fair impression of how a Windows machine behaves. However, you can expand or reduce the list according to your needs. You can also expand your Nagwin installation by adding new plugins.

Resolving problems flagged as critical by Nagios are operational issues. We can't provide any help as they are very implementation-specific.

mig1980
Offline
Last seen: 8 years 9 months ago
Joined: 13.10.2012 - 01:17
I have noticed that as of

I have noticed that as of yesterday (after I logged off of the nagios main server) the web interface for Nagios Core stopped updating. The "Last Check" under the Services section has yesterday's date for all and "Duration" right next to it under the Services section continues to count since yesterday (i.e. 1d 0h 35m 51s).

 

Does this mean the service is not updating any longer? If so, how can I get it to update again? This is the case for the localhost and for the one test server I have monitoring.

itefix
Offline
Last seen: 2 days 38 min ago
Joined: 01.05.2008 - 21:33
You need to check if services

You need to check if services are running and error messages in log files.

mig1980
Offline
Last seen: 8 years 9 months ago
Joined: 13.10.2012 - 01:17
The services stopped running

The services stopped running and the nagwin_nagios service stops as soon as I start it. I receive the following error in the event viewer:

 

Source: Nagwin_Nagios Type: Error

The description for Event ID (0) in Source (Nagwin_Nagios) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages form remote computer...

 

The nagios-stdout.log file says the following over and over: "Warning: Attempting to execute the command "/usr/bin/perl /var/opt/pnp4nagios/libexec/process_perfdata.pl" resulted in a return code of 127.  Make sure the script or binary you are trying to execute actually exists..."

itefix
Offline
Last seen: 2 days 38 min ago
Joined: 01.05.2008 - 21:33
There is a glitch in the

There is a glitch in the installer: Performance logging is dependent on Perl which is not a part of free edition. You can turn off performance logging in nagios.cfg:

process_performance_data=0


Alternatively, you can try to setup a perl environment.

mig1980
Offline
Last seen: 8 years 9 months ago
Joined: 13.10.2012 - 01:17
I made the change but how do

I made the change but how do I get the Nagwin_Nagios service to start? Every time I try to start it I receive a Services error saying: "The Nagwin-Nagios sevriceon Local Computer started and then stopped. Some services stop automatically if they have no work to do, for example, the Performance Logs and Alerts service.

 

Is it suppose to not start (only when it needs to)?

itefix
Offline
Last seen: 2 days 38 min ago
Joined: 01.05.2008 - 21:33
This a clear error situation

This a clear error situation and there must be some explanation in log files or event log.

mig1980
Offline
Last seen: 8 years 9 months ago
Joined: 13.10.2012 - 01:17
I took a look at the logs and

I took a look at the logs and all that shows up is the service trying to start and it gets recorded in the nagios-stdout.log file with a different PID every time.

 

Here is what shows in the log file after trying to start it twice:

 


Nagios Core 3.3.1
Copyright (c) 2009-2011 Nagios Core Development Team and Community Contributors
Copyright (c) 1999-2009 Ethan Galstad
Last Modified: 07-25-2011
License: GPL

Website: http://www.nagios.org
Nagios 3.3.1 starting... (PID=376)
Local time is Tue Oct 23 08:40:30 PDT 2012

Nagios Core 3.3.1
Copyright (c) 2009-2011 Nagios Core Development Team and Community Contributors
Copyright (c) 1999-2009 Ethan Galstad
Last Modified: 07-25-2011
License: GPL

Website: http://www.nagios.org
Nagios 3.3.1 starting... (PID=3060)
Local time is Tue Oct 23 08:43:35 PDT 2012


 

Any ideas?

mig1980
Offline
Last seen: 8 years 9 months ago
Joined: 13.10.2012 - 01:17
When I run the Check Nagios

When I run the Check Nagios Configuration from the All Programs section, I receive the following response:


 Check Nagios Configuration
Tue 10/23/2012
10:47 AM

Nagios Core 3.3.1
Copyright (c) 2009-2011 Nagios Core Development Team and Community Contributors
Copyright (c) 1999-2009 Ethan Galstad
Last Modified: 07-25-2011
License: GPL

Website: http://www.nagios.org
Reading configuration data...
   Read main config file okay...
Warning: Could not get passwd entry for 'SvcNagwin'
Warning: Possibly root user failed dropping privileges with initgroups()
   Failed to drop privileges.  Aborting.

***> One or more problems was encountered while processing the config files...

     Check your configuration file(s) to ensure that they contain valid
     directives and data defintions.  If you are upgrading from a previous
     version of Nagios, you should be aware that some variables/definitions
     may have been removed or modified in this version.  Make sure to read
     the HTML documentation regarding the config files, as well as the
     'Whats New' section to find out what has changed.

itefix
Offline
Last seen: 2 days 38 min ago
Joined: 01.05.2008 - 21:33
It is something broken here.

It is something broken here. Please uninstall everything, make sure that the service account SvcNagwin and the account nagiosadmin doesn't exist, remove the installation directory totally and try to reinstall as administrator (right click and run as administrator)

mig1980
Offline
Last seen: 8 years 9 months ago
Joined: 13.10.2012 - 01:17
So I uninstalled everything,

So I uninstalled everything, made sure the accounts no longer existed. I then reinstalled everything and it worked for about 8 hours and then it broke again. The web interface is no longer reporting the service status.

 

The errors I see are:

 

Warning: The check of host 'localhost' looks like it was orphaned (results never came back).  I'm scheduling an immediate check of the host...

Warning: The check of service 'Virtual memory' on host 'localhost' looks like it was orphaned (results never came back).  I'm scheduling an immediate check of the service...

Warning: The check of service 'Physical memory' on host 'localhost' looks like it was orphaned (results never came back).  I'm scheduling an immediate check of the service...

 

and many others...

 

Does this application even work with Windows 2003 Server as the host? Or am I just wasting my time?

 

The last time anything recorded in the log file was the last day it reported the status for the services.

itefix
Offline
Last seen: 2 days 38 min ago
Joined: 01.05.2008 - 21:33
There may be some intrusive

There may be some intrusive software on your system blocking Nagwin to operate properly. Check Cygwin FAQ 4.42 about the issue. Some software don't simply play well.